STM32F7 Discovery - Audio input and output

13 posts / 0 new
Last post
Chirag
Offline
Last seen: 5 days 16 hours ago
Joined: 08/29/2018 - 5:59am
STM32F7 Discovery - Audio input and output

Hello everyone,

I am using stm32f7, and I am trying to receive audio signal(any kind of - square wave, sine wave etc) from audio line in and transmit the same signal from audio out(headphone jack). If anyone has any idea regarding this or any relevant example would be great helpful. 

Thank You. 

Andrew
Offline
Last seen: 5 hours 50 min ago
Joined: 04/12/2018 - 9:25am

Hi Chirag,

Could I have some more detail about what part of the process is giving you trouble? Are you using our  STM32F746 Reference BSP from the downloads page? 

-Andrew

Chirag
Offline
Last seen: 5 days 16 hours ago
Joined: 08/29/2018 - 5:59am

Hello Andrew, Thanks for responding, I am using an example of BSP audio from STM32CubeMx software(Keil environment for C) - this example deals with onboard device 'microphone'  as audio input and 'audio line out (headphone)' as output. In short, whatever the sound propagates to the microphone- generates the audio signal through headphone. And I am trying to replace 'microphone' to 'audio line in' using C Keil. but seems difficult. 

Now I am using STMicro 6.18.02, and tried some examples but seems difficult to understand the software. I also tried  STM32F746 Reference BSP example from download pages but shows no response on the board. 

I want to receive audio signal from 'audio line in' and transmitte the same signal through headphone. I have tried to change blocks and run the file as shown in attached picture, but its also not working. And I also have a truble with target, I am following every steps from audio weaver stm32f7xx  users guide, and can't open STM32F746_Discovery_MDK_ARM.bin file and won't be able to detect  STM32f7 speaker in sound properties of windows. Hope you got it and if you have any suggestion please let me know. 

Thank You.

Andrew
Offline
Last seen: 5 hours 50 min ago
Joined: 04/12/2018 - 9:25am

Hi Chirag,

Can you give me the specific model of the board that you are trying to use? 

Thanks

Chirag
Offline
Last seen: 5 days 16 hours ago
Joined: 08/29/2018 - 5:59am

Hi Andrew, 

I am Using STM32F746NG Discovery. 

Thank You.

Andrew
Offline
Last seen: 5 hours 50 min ago
Joined: 04/12/2018 - 9:25am

Hello again, 

You may be describing a board that is not quite the same as what our reference BSP is designed for. Could you verify that this is the exact same board that you are using? 

https://www.st.com/content/ccc/resource/technical/document/data_brief/b3/48/2b/e3/d2/12/45/c1/DM00179227.pdf/files/DM00179227.pdf/jcr:content/translations/en.DM00179227.pdf

 

Chirag
Offline
Last seen: 5 days 16 hours ago
Joined: 08/29/2018 - 5:59am

This is exactly the same board I am using. As written in datasheet STM32F746NG Discovery.  

Andrew
Offline
Last seen: 5 hours 50 min ago
Joined: 04/12/2018 - 9:25am

Interesting! 

ST Micro Designer (6.18.02) will not work with a target unless the BSP is successfully flashed to the board, so that is the first issue for us to troubleshoot. Are you getting any error messages after flashing the board (following our instructions explicity), or is it simply not responding? 

Sorry that you are having this issue, and we are here to help. Thanks again,

Andrew

Chirag
Offline
Last seen: 5 days 16 hours ago
Joined: 08/29/2018 - 5:59am

Hello,

Thanks for replay, I tried several time to configure target according to your document, and while changing the target to USB in STMicro, I am getting an error as shown in attachment. The very last step of configuration according to document. All other steps were performed very well. 

Andrew
Offline
Last seen: 5 hours 50 min ago
Joined: 04/12/2018 - 9:25am

Hi again Chirag. I will be diving into this issue more later today. In the meantime, do you have any spare cables to try? I have seen similar USB issues while using certain cables. 

Chirag
Offline
Last seen: 5 days 16 hours ago
Joined: 08/29/2018 - 5:59am

Hello,

I have tried three different USB cables, all of them works fine with Keil and Matlab target, but with STMicro is the same problem. 

Thank You.  

Andrew
Offline
Last seen: 5 hours 50 min ago
Joined: 04/12/2018 - 9:25am

Hi Chirag,

I am investigating and will get back to you with more suggestions ASAP. Thank you. 

Andrew
Offline
Last seen: 5 hours 50 min ago
Joined: 04/12/2018 - 9:25am

Hi Chirag,

Sorry for the delay. We have not been able to consistently reproduce the issue. However, we do see this error message occasionally and it can always be fixed by one of the following..

  1. Restart/Reflash the board
  2. Restart your PC
  3. Unplug all other USB devices
  4. Do not use a USB hub for connection

 

Let me know if you are still having issues after trying all of those things.